Virtual Machines

Using the EVM devnet

To get up and running, you need to install Mallet and start compiling your smart contracts. Then you can start experimenting and identify any issues with your smart contracts.

Known issues

There currently are three known issues:

  • Only supports up to EVM version Byzantium. Therefore, Solidity compiler 0.5.1 is recommended.
  • RPC eth_logs does not return any logs.
  • eth_getWork is not returning expected values.

Last updated: February 25, 2021 08:00 UTC